summaryrefslogtreecommitdiffstats
path: root/tv/2configs/vim.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-05-25 00:39:17 +0200
committertv <tv@krebsco.de>2016-05-25 00:46:59 +0200
commitbd64bc1eb05cc95a32165288481d9ff9be4f33c8 (patch)
treec4d025316202fd58e70d22a2c7a0e6db88896a7f /tv/2configs/vim.nix
parent37ee40759f1e6feda51fb36dd3c951b4f3045944 (diff)
tv nix.vim: admit Haskell comments
Diffstat (limited to 'tv/2configs/vim.nix')
-rw-r--r--tv/2configs/vim.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tv/2configs/vim.nix b/tv/2configs/vim.nix
index 6e205948..6eefca30 100644
--- a/tv/2configs/vim.nix
+++ b/tv/2configs/vim.nix
@@ -111,6 +111,10 @@ let
syn match String /"\([^\\"]\|\\.\)*"/
syn match Comment /\(^\|\s\)#.*/
+ " Haskell comments
+ syn region Comment start=/\(^\|\s\){-#/ end=/#-}/
+ syn match Comment /\(^\|\s\)--.*/
+
let b:current_syntax = "nix"
''}