summaryrefslogtreecommitdiffstats
path: root/tv/2configs/vim.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-06-20 19:30:14 +0200
committertv <tv@krebsco.de>2017-06-20 19:30:14 +0200
commita9f4ad7586bfb543cdcdeacf93b71bdce506621a (patch)
treebe74bac26ea69ba9a7a6519ef12db86d1a953927 /tv/2configs/vim.nix
parent57c6b890f9088bb333eeab215ecfeca9d09ce3ef (diff)
concat: RIP
Diffstat (limited to 'tv/2configs/vim.nix')
-rw-r--r--tv/2configs/vim.nix27
1 files changed, 15 insertions, 12 deletions
diff --git a/tv/2configs/vim.nix b/tv/2configs/vim.nix
index b534c3f4..93ed46dc 100644
--- a/tv/2configs/vim.nix
+++ b/tv/2configs/vim.nix
@@ -297,18 +297,21 @@ let {
alldirs = attrValues dirs ++ map dirOf (attrValues files);
in unique (sort lessThan alldirs);
- vim-wrapper = pkgs.concat "vim" [
- pkgs.vim_configurable
- (pkgs.writeDashBin "vim" ''
- set -efu
- (umask 0077; exec ${pkgs.coreutils}/bin/mkdir -p ${toString mkdirs})
- if test $# = 0 && test -e "$PWD/.ctrlpignore"; then
- set -- +CtrlP
- fi
- # vim-orgmode needs Python, thus vim_configurable instead of just vim
- exec ${pkgs.vim_configurable}/bin/vim "$@"
- '')
- ];
+ vim-wrapper = pkgs.symlinkJoin {
+ name = "vim";
+ paths = [
+ pkgs.vim_configurable
+ (pkgs.writeDashBin "vim" ''
+ set -efu
+ (umask 0077; exec ${pkgs.coreutils}/bin/mkdir -p ${toString mkdirs})
+ if test $# = 0 && test -e "$PWD/.ctrlpignore"; then
+ set -- +CtrlP
+ fi
+ # vim-orgmode needs Python, thus vim_configurable instead of just vim
+ exec ${pkgs.vim_configurable}/bin/vim "$@"
+ '')
+ ];
+ };
vimrc = pkgs.writeText "vimrc" ''
set nocompatible