summaryrefslogtreecommitdiffstats
path: root/tv/2configs/vim.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-06-09 04:22:46 +0200
committertv <tv@krebsco.de>2016-06-09 04:31:05 +0200
commit104d5a6d47f9b33c3a075f1e4d2ce9ccacc836ae (patch)
tree91622b76efaac150b722255ced02aa78635a0e5c /tv/2configs/vim.nix
parent94e05ff7c470404464392d8d7b61cd3c502684b5 (diff)
tv hack.vim: init at 1.0
Diffstat (limited to 'tv/2configs/vim.nix')
-rw-r--r--tv/2configs/vim.nix27
1 files changed, 23 insertions, 4 deletions
diff --git a/tv/2configs/vim.nix b/tv/2configs/vim.nix
index 82d06f63..ee2cbdb1 100644
--- a/tv/2configs/vim.nix
+++ b/tv/2configs/vim.nix
@@ -23,6 +23,28 @@ let
sha256 = "0z47zq9rqh06ny0q8lpcdsraf3lyzn9xvb59nywnarf3nxrk6hx0";
};
})
+ ((rtp: rtp // { inherit rtp; }) (pkgs.writeTextFile (let
+ name = "hack";
+ version = "1.0";
+ in {
+ name = "vim-color-${name}-${version}";
+ destination = "/colors/${name}.vim";
+ text = /* vim */ ''
+ set background=dark
+ hi clear
+ if exists("syntax_on")
+ syntax clear
+ endif
+
+ let colors_name = ${toJSON name}
+
+ hi Normal ctermbg=235
+ hi Comment ctermfg=240
+
+ hi Tabstop ctermbg=16
+ hi TrailingSpace ctermbg=88
+ '';
+ })))
];
dirs = {
@@ -79,14 +101,11 @@ let
filetype plugin indent on
set t_Co=256
- colorscheme industry
+ colorscheme hack
syntax on
au Syntax * syn match Tabstop containedin=ALL /\t\+/
- \ | hi Tabstop ctermbg=16
\ | syn match TrailingSpace containedin=ALL /\s\+$/
- \ | hi TrailingSpace ctermbg=88
- \ | hi Normal ctermfg=White
au BufRead,BufNewFile *.hs so ${hs.vim}