summaryrefslogtreecommitdiffstats
path: root/tv/2configs/vim.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-06-09 13:22:47 +0200
committertv <tv@krebsco.de>2016-06-10 16:04:55 +0200
commit0b6103498b4555df63e29a31905627e66e25f610 (patch)
tree5509d5caa95f7935f9472b5930150d06c6914ccd /tv/2configs/vim.nix
parentf94ce5630a46210904960af047261339fdaa1afe (diff)
tv vim-syntax-vim: init at 1.0.0
Diffstat (limited to 'tv/2configs/vim.nix')
-rw-r--r--tv/2configs/vim.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/tv/2configs/vim.nix b/tv/2configs/vim.nix
index e6b9bf20..0eb67fc5 100644
--- a/tv/2configs/vim.nix
+++ b/tv/2configs/vim.nix
@@ -44,6 +44,19 @@ let
hi TrailingSpace ctermbg=88
'';
})))
+ ((rtp: rtp // { inherit rtp; }) (pkgs.writeTextFile (let
+ name = "vim";
+ in {
+ name = "vim-syntax-${name}-1.0.0";
+ destination = "/syntax/${name}.vim";
+ text = /* vim */ ''
+ ${concatMapStringsSep "\n" (s: /* vim */ ''
+ syn keyword vimColor${s} ${s}
+ \ containedin=ALLBUT,vimComment,vimLineComment
+ hi vimColor${s} ctermfg=${s}
+ '') (map (i: lpad 3 "0" (toString i)) (range 0 255))}
+ '';
+ })))
];
dirs = {