summaryrefslogtreecommitdiffstats
path: root/tv/2configs/urlwatch.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2019-08-13 15:35:12 +0200
committerlassulus <lassulus@lassul.us>2019-08-13 15:35:12 +0200
commit0699b41b05a1f9cd133c15c3aadf70c3a45170f6 (patch)
tree0bdd752d8a9ec64acb12ff160826a19b2e11e95c /tv/2configs/urlwatch.nix
parente754ced01e2d5ef84dabba391bba2f372694b7cb (diff)
parent681075a8f41ecfbac4c113481adde4d61f497c36 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'tv/2configs/urlwatch.nix')
-rw-r--r--tv/2configs/urlwatch.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/tv/2configs/urlwatch.nix b/tv/2configs/urlwatch.nix
index 40dc7d23..378b5d16 100644
--- a/tv/2configs/urlwatch.nix
+++ b/tv/2configs/urlwatch.nix
@@ -1,9 +1,15 @@
with import <stockholm/lib>;
{ config, pkgs, ... }: let
- json = url: {
+ exec = filename: args: url: {
inherit url;
- filter = "system:${pkgs.jq}/bin/jq .";
+ filter = "system:${
+ concatMapStringsSep " " shell.escape ([filename] ++ toList args)
+ }";
};
+ json = json' ["."];
+ json' = exec "${pkgs.jq}/bin/jq";
+ xml = xml' ["--format" "-"];
+ xml' = exec "${pkgs.libxml2}/bin/xmllint";
in {
krebs.urlwatch = {
enable = true;