summaryrefslogtreecommitdiffstats
path: root/tv/2configs/ppp.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-10-27 01:35:04 +0200
committertv <tv@krebsco.de>2017-10-27 01:35:04 +0200
commit36c01359dcffd3c7424366b9c43eb0b8baae666a (patch)
tree568d01b88d4c190f366b9b77f1ab65e189e602e1 /tv/2configs/ppp.nix
parent6c8acbdf9ab464f09d2c08751528d31a81612351 (diff)
tv: netzclub -> ppp
Diffstat (limited to 'tv/2configs/ppp.nix')
-rw-r--r--tv/2configs/ppp.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/tv/2configs/ppp.nix b/tv/2configs/ppp.nix
new file mode 100644
index 00000000..9cc7568a
--- /dev/null
+++ b/tv/2configs/ppp.nix
@@ -0,0 +1,32 @@
+{ pkgs, ... }: {
+
+ # usage: pppd call default
+
+ environment.etc."ppp/peers/default".text = ''
+ /dev/ttyACM2
+ 921600
+ crtscts
+ defaultroute
+ holdoff 10
+ lock
+ maxfail 0
+ noauth
+ nodetach
+ noipdefault
+ passive
+ persist
+ usepeerdns
+ connect "${pkgs.ppp}/bin/chat -f ${pkgs.writeText "default.chat" ''
+ ABORT "BUSY"
+ ABORT "NO CARRIER"
+ REPORT CONNECT
+ "" "ATDT*99#"
+ CONNECT
+ ''}"
+ '';
+
+ environment.systemPackages = [
+ pkgs.ppp
+ ];
+
+}