summaryrefslogtreecommitdiffstats
path: root/tv/2configs/im.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-02-17 17:23:19 +0100
committertv <tv@krebsco.de>2016-02-17 17:23:19 +0100
commit468f294635523a39eaf1a6794571948066b63a1c (patch)
tree1b4d7a32cb5eb2643caeb3fae052f45dd1a7d292 /tv/2configs/im.nix
parent2d79335e34d639657bd0045f9a6b777778a5ad82 (diff)
tv im: init
Diffstat (limited to 'tv/2configs/im.nix')
-rw-r--r--tv/2configs/im.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/tv/2configs/im.nix b/tv/2configs/im.nix
new file mode 100644
index 00000000..db1be7f0
--- /dev/null
+++ b/tv/2configs/im.nix
@@ -0,0 +1,24 @@
+{ config, lib, pkgs, ... }:
+with config.krebs.lib;
+{
+ environment.systemPackages = with pkgs; [
+ (pkgs.writeDashBin "im" ''
+ export PATH=${makeSearchPath "bin" (with pkgs; [
+ tmux
+ gnugrep
+ weechat
+ ])}
+ if tmux list-sessions -F\#S | grep -q '^im''$'; then
+ exec tmux attach -t im
+ else
+ exec tmux new -s im weechat
+ fi
+ '')
+ ];
+ services.bitlbee = {
+ enable = true;
+ plugins = [
+ pkgs.bitlbee-facebook
+ ];
+ };
+}