summaryrefslogtreecommitdiffstats
path: root/tv/2configs/hw/AO753.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-29 01:09:54 +0100
committertv <tv@shackspace.de>2015-10-29 01:33:14 +0100
commit31074d797c62f64009375e60b15d4b55a8937cab (patch)
tree33a768d0a61a39fff3906413087a1ad2096eb3ec /tv/2configs/hw/AO753.nix
parent00d03622d187397fd0cb46c17fe1f6750883d774 (diff)
tv config: split stuff into fs and hw
Diffstat (limited to 'tv/2configs/hw/AO753.nix')
-rw-r--r--tv/2configs/hw/AO753.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/tv/2configs/hw/AO753.nix b/tv/2configs/hw/AO753.nix
new file mode 100644
index 00000000..acd9ee32
--- /dev/null
+++ b/tv/2configs/hw/AO753.nix
@@ -0,0 +1,46 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ../smartd.nix
+ ];
+
+ boot.loader.grub = {
+ device = "/dev/sda";
+ splashImage = null;
+ };
+
+ boot.initrd.availableKernelModules = [
+ "ahci"
+ ];
+
+ boot.kernelModules = [
+ "kvm-intel"
+ "wl"
+ ];
+
+ boot.extraModulePackages = [
+ config.boot.kernelPackages.broadcom_sta
+ ];
+
+ networking.wireless.enable = true;
+
+ nix = {
+ buildCores = 2;
+ maxJobs = 2;
+ daemonIONiceLevel = 1;
+ daemonNiceLevel = 1;
+ };
+
+ services.logind.extraConfig = ''
+ HandleHibernateKey=ignore
+ HandleLidSwitch=ignore
+ HandlePowerKey=ignore
+ HandleSuspendKey=ignore
+ '';
+
+ nixpkgs.config = {
+ allowUnfree = false;
+ allowUnfreePredicate = (x: pkgs.lib.hasPrefix "broadcom-sta-" x.name);
+ };
+}