summaryrefslogtreecommitdiffstats
path: root/tv/2configs/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-11-08 11:53:29 +0100
committertv <tv@krebsco.de>2015-11-08 11:53:29 +0100
commit60faa6e3cf3b592a4aad71b246fbe2abdd699b9c (patch)
tree36a911bf0e22792789e17425c41d94bc8bd6e483 /tv/2configs/default.nix
parentb166b6c29d2cfd39348073b9873da13a1581ad61 (diff)
tv: remove legacy users
Diffstat (limited to 'tv/2configs/default.nix')
-rw-r--r--tv/2configs/default.nix43
1 files changed, 9 insertions, 34 deletions
diff --git a/tv/2configs/default.nix b/tv/2configs/default.nix
index d31862b6..688f8f9c 100644
--- a/tv/2configs/default.nix
+++ b/tv/2configs/default.nix
@@ -27,6 +27,7 @@ with lib;
networking.hostName = config.krebs.build.host.name;
imports = [
+ <secrets>
./vim.nix
{
# stockholm dependencies
@@ -35,40 +36,14 @@ with lib;
];
}
{
- # TODO never put hashedPassword into the store
- users.extraUsers =
- mapAttrs (_: h: { hashedPassword = h; })
- (import <secrets/hashedPasswords.nix>);
- }
- {
- users.groups.subusers.gid = 1093178926; # genid subusers
- }
- {
- users.defaultUserShell = "/run/current-system/sw/bin/bash";
- users.mutableUsers = false;
- }
- {
- users.extraUsers = {
- root = {
- openssh.authorizedKeys.keys = [
- config.krebs.users.tv.pubkey
- config.krebs.users.tv_xu.pubkey
- ];
- };
- tv = {
- uid = 1337;
- group = "users";
- home = "/home/tv";
- createHome = true;
- useDefaultShell = true;
- extraGroups = [
- "audio"
- "video"
- "wheel"
- ];
- openssh.authorizedKeys.keys = [
- config.krebs.users.tv.pubkey
- ];
+ users = {
+ defaultUserShell = "/run/current-system/sw/bin/bash";
+ mutableUsers = false;
+ users = {
+ tv = {
+ isNormalUser = true;
+ uid = 1337;
+ };
};
};
}