summaryrefslogtreecommitdiffstats
path: root/tv/2configs/binary-cache/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-11-24 23:07:48 +0100
committertv <tv@krebsco.de>2016-11-24 23:07:48 +0100
commit8f946dd2fc4d2577fa2ae0c251a1d672bc139077 (patch)
tree5112a89b57390137b8cdd9f106cc731c9bf7d422 /tv/2configs/binary-cache/default.nix
parentedb899745b701c717e9d44785c304f9b791b84d0 (diff)
tv binary-cache: replace wu by xu and use hosts.binary-cache.pubkey
Diffstat (limited to 'tv/2configs/binary-cache/default.nix')
-rw-r--r--tv/2configs/binary-cache/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/tv/2configs/binary-cache/default.nix b/tv/2configs/binary-cache/default.nix
new file mode 100644
index 00000000..5902f189
--- /dev/null
+++ b/tv/2configs/binary-cache/default.nix
@@ -0,0 +1,33 @@
+{ config, lib, pkgs, ... }: with import <stockholm/lib>;
+{
+ environment.etc."binary-cache.pubkey".text =
+ config.krebs.build.host.binary-cache.pubkey;
+
+ services.nix-serve = {
+ enable = true;
+ secretKeyFile = config.krebs.secret.files.binary-cache-seckey.path;
+ };
+
+ systemd.services.nix-serve = {
+ requires = ["secret.service"];
+ after = ["secret.service"];
+ };
+
+ krebs.secret.files.binary-cache-seckey = {
+ path = "/run/secret/nix-serve.key";
+ owner.name = "nix-serve";
+ source-path = toString <secrets> + "/nix-serve.key";
+ };
+
+ krebs.nginx = {
+ enable = true;
+ servers.nix-serve = {
+ server-names = [
+ "cache.${config.krebs.build.host.name}.gg23"
+ ];
+ locations = singleton (nameValuePair "/" ''
+ proxy_pass http://localhost:${toString config.services.nix-serve.port};
+ '');
+ };
+ };
+}