summaryrefslogtreecommitdiffstats
path: root/tv/1systems/wu.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-01-08 13:07:58 +0100
committertv <tv@krebsco.de>2017-01-08 14:52:56 +0100
commit5d7a3d0cccc260565577a6441eadf12c1463a03d (patch)
treec1b1aa8c7b2a16937890cdc8e6117443cd07895c /tv/1systems/wu.nix
parent9779351be952095ed55ad4ccee98452a8838cfb9 (diff)
wu: resurrect
Diffstat (limited to 'tv/1systems/wu.nix')
-rw-r--r--tv/1systems/wu.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/tv/1systems/wu.nix b/tv/1systems/wu.nix
index d5be57bb..a9d7e94e 100644
--- a/tv/1systems/wu.nix
+++ b/tv/1systems/wu.nix
@@ -23,7 +23,6 @@ with import <stockholm/lib>;
# stockholm
gnumake
hashPassword
- haskellPackages.lentil
parallel
# root
@@ -47,7 +46,6 @@ with import <stockholm/lib>;
p7zip
push
qrencode
- texLive
tmux
#ack
@@ -116,18 +114,23 @@ with import <stockholm/lib>;
boot.initrd.luks = {
cryptoModules = [ "aes" "sha512" "xts" ];
devices = [
- { name = "home"; device = "/dev/vg840/enchome"; preLVM = false; }
+ { name = "wuca"; device = "/dev/sda2"; }
];
};
fileSystems = {
"/" = {
- device = "/dev/mapper/vg840-wuroot";
+ device = "/dev/mapper/wuvga-root";
+ fsType = "btrfs";
+ options = ["defaults" "noatime" "ssd" "compress=lzo"];
+ };
+ "/bku" = {
+ device = "/dev/mapper/wuvga-bku";
fsType = "btrfs";
options = ["defaults" "noatime" "ssd" "compress=lzo"];
};
"/home" = {
- device = "/dev/mapper/home";
+ device = "/dev/mapper/wuvga-home";
fsType = "btrfs";
options = ["defaults" "noatime" "ssd" "compress=lzo"];
};
@@ -174,5 +177,5 @@ with import <stockholm/lib>;
KERNEL=="hpet", GROUP="audio"
'';
- services.virtualboxHost.enable = true;
+ virtualisation.virtualbox.host.enable = true;
}