summaryrefslogtreecommitdiffstats
path: root/tv/1systems/nomic.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-07-06 21:47:47 +0200
committertv <tv@krebsco.de>2017-07-10 11:05:48 +0200
commit7fdc46bb9d911838edfa723d985ede6a604c0c5a (patch)
tree3ceb366c12f0bc229cfcd5fce6c2f409e29fe06b /tv/1systems/nomic.nix
parentfc3f5d3d56a299b7b46c1a42d3fec57c536a5917 (diff)
move source config from module system to 1systems/*/source.nix
Diffstat (limited to 'tv/1systems/nomic.nix')
-rw-r--r--tv/1systems/nomic.nix74
1 files changed, 0 insertions, 74 deletions
diff --git a/tv/1systems/nomic.nix b/tv/1systems/nomic.nix
deleted file mode 100644
index 9b950225..00000000
--- a/tv/1systems/nomic.nix
+++ /dev/null
@@ -1,74 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with import <stockholm/lib>;
-
-{
- krebs.build.host = config.krebs.hosts.nomic;
-
- imports = [
- ../.
- ../2configs/hw/x220.nix
- ../2configs/exim-retiolum.nix
- ../2configs/gitrepos.nix
- ../2configs/im.nix
- ../2configs/mail-client.nix
- ../2configs/nginx/public_html.nix
- ../2configs/pulse.nix
- ../2configs/retiolum.nix
- ../2configs/xserver
- ];
-
- boot.initrd.luks = {
- cryptoModules = [ "aes" "sha512" "xts" ];
- devices = [
- { name = "luks1"; device = "/dev/sda2"; }
- ];
- };
-
- # Don't use UEFI because current disk was partitioned/formatted for AO753.
- # TODO remove following bool.loader section after repartitioning/reformatting
- boot.loader = {
- grub = {
- device = "/dev/sda";
- splashImage = null;
- };
- systemd-boot.enable = mkForce false;
- };
-
- fileSystems."/" =
- { device = "/dev/mapper/nomic1-root";
- fsType = "btrfs";
- };
-
- fileSystems."/boot" =
- { device = "/dev/sda1";
- fsType = "ext4";
- };
-
- fileSystems."/home" =
- { device = "/dev/mapper/nomic1-home";
- fsType = "btrfs";
- };
-
- swapDevices = [ ];
-
- # TODO base
- boot.tmpOnTmpfs = true;
-
- environment.systemPackages = with pkgs; [
- (writeDashBin "play" ''
- set -euf
- mpv() { exec ${mpv}/bin/mpv "$@"; }
- case $1 in
- deepmix) mpv http://deepmix.ru/deepmix128.pls;;
- groovesalad) mpv http://somafm.com/play/groovesalad;;
- ntslive) mpv http://listen2.ntslive.co.uk/listen.pls;;
- *)
- echo "$0: bad argument: $*" >&2
- exit 23
- esac
- '')
- gnupg
- tmux
- ];
-}