summaryrefslogtreecommitdiffstats
path: root/tv/1systems/mu/config.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-08-18 09:06:27 +0200
committertv <tv@krebsco.de>2017-08-18 09:06:27 +0200
commitb9a4e834c06bc32fa38389e13c0ec42467c0fc46 (patch)
tree762f1fdc6d82668dcae34bdd250bd1d3225e0e4d /tv/1systems/mu/config.nix
parente7b1359a3345e9929120506c3da5eea08ec35338 (diff)
tv mu: 300G HDD -> 120G SSD
Diffstat (limited to 'tv/1systems/mu/config.nix')
-rw-r--r--tv/1systems/mu/config.nix19
1 files changed, 10 insertions, 9 deletions
diff --git a/tv/1systems/mu/config.nix b/tv/1systems/mu/config.nix
index 08948187..ee0f4f7f 100644
--- a/tv/1systems/mu/config.nix
+++ b/tv/1systems/mu/config.nix
@@ -15,9 +15,9 @@ with import <stockholm/lib>;
tv.x0vncserver.enable = true;
# hardware configuration
- boot.initrd.luks.devices = [
- { name = "vgmu1"; device = "/dev/sda2"; }
- ];
+ boot.initrd.luks.devices.muca = {
+ device = "/dev/disk/by-uuid/a8796bb3-6c03-4ddf-b2e4-c2e44c51d352";
+ };
boot.initrd.luks.cryptoModules = [ "aes" "sha512" "xts" ];
boot.initrd.availableKernelModules = [ "ahci" ];
boot.kernelModules = [ "fbcon" "kvm-intel" ];
@@ -25,16 +25,17 @@ with import <stockholm/lib>;
fileSystems = {
"/" = {
- device = "/dev/vgmu1/nixroot";
- fsType = "ext4";
- options = [ "defaults" "noatime" ];
+ device = "/dev/mapper/muvga-root";
+ fsType = "btrfs";
+ options = ["defaults" "noatime" "ssd" "compress=lzo"];
};
"/home" = {
- device = "/dev/vgmu1/home";
- options = [ "defaults" "noatime" ];
+ device = "/dev/mapper/muvga-home";
+ fsType = "btrfs";
+ options = ["defaults" "noatime" "ssd" "compress=lzo"];
};
"/boot" = {
- device = "/dev/sda1";
+ device = "/dev/disk/by-uuid/DC38-F165";
};
};