summaryrefslogtreecommitdiffstats
path: root/tv/1systems/cd/config.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-07-28 21:26:31 +0200
committertv <tv@krebsco.de>2017-07-28 21:27:07 +0200
commit8012a06010cf0ed8bd30fde06c44dd9ec7579155 (patch)
tree0d4eb9f92703e52bd77bab3bf4f239978a0dec9c /tv/1systems/cd/config.nix
parent32d8c202b0ec037dcf78ebf6ecad730cfb9c5272 (diff)
tv cd: use host's ip4 addr
Diffstat (limited to 'tv/1systems/cd/config.nix')
-rw-r--r--tv/1systems/cd/config.nix17
1 files changed, 9 insertions, 8 deletions
diff --git a/tv/1systems/cd/config.nix b/tv/1systems/cd/config.nix
index f78bcafe..341a62e4 100644
--- a/tv/1systems/cd/config.nix
+++ b/tv/1systems/cd/config.nix
@@ -1,8 +1,9 @@
-{ config, lib, pkgs, ... }:
-
with import <stockholm/lib>;
+{ config, pkgs, ... }: let
+
+ bestGuessGateway = addr: elemAt (match "(.*)(\.[^.])" addr) 0 + ".1";
-{
+in {
krebs.build.host = config.krebs.hosts.cd;
imports = [
@@ -13,14 +14,14 @@ with import <stockholm/lib>;
<stockholm/tv/2configs/retiolum.nix>
];
- networking = {
+ networking = let
+ address = config.krebs.build.host.nets.internet.ip4.addr;
+ in {
+ defaultGateway = bestGuessGateway address;
interfaces.enp2s1.ip4 = singleton {
- address = let
- addr = "45.62.237.203";
- in assert config.krebs.build.host.nets.internet.ip4.addr == addr; addr;
+ inherit address;
prefixLength = 24;
};
- defaultGateway = "45.62.237.1";
nameservers = ["8.8.8.8"];
};