summaryrefslogtreecommitdiffstats
path: root/tv/1systems/caxi.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-07-03 20:22:21 +0200
committertv <tv@krebsco.de>2016-07-03 20:22:45 +0200
commitcc6b1f6ad14914351e2885a6c7c283e451b61212 (patch)
treeaa2e938c8f3068923457af0e284890c02ab9092c /tv/1systems/caxi.nix
parent814e823fcd644bfde8a2e320e0f9887e61df122b (diff)
caxi: init
Diffstat (limited to 'tv/1systems/caxi.nix')
-rw-r--r--tv/1systems/caxi.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/tv/1systems/caxi.nix b/tv/1systems/caxi.nix
new file mode 100644
index 00000000..5bfacd99
--- /dev/null
+++ b/tv/1systems/caxi.nix
@@ -0,0 +1,25 @@
+{ config, ... }:
+
+with config.krebs.lib;
+
+{
+ krebs.build.host = config.krebs.hosts.caxi;
+
+ imports = [
+ ../.
+ ../2configs/hw/CAC-Developer-1.nix
+ ../2configs/fs/CAC-CentOS-7-64bit.nix
+ ../2configs/retiolum.nix
+ ];
+
+ networking = let
+ inherit (config.krebs.build.host.nets.internet) ip4;
+ in {
+ interfaces.enp2s1.ip4 = singleton {
+ address = ip4.addr;
+ prefixLength = fromJSON (head (match ".*/([0-9]+)" ip4.prefix));
+ };
+ defaultGateway = head (match "([^/]*)\.0/[0-9]+" ip4.prefix) + ".1";
+ nameservers = ["8.8.8.8"];
+ };
+}