summaryrefslogtreecommitdiffstats
path: root/tv/1systems/alnus.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-07-06 21:47:47 +0200
committertv <tv@krebsco.de>2017-07-10 11:05:48 +0200
commit7fdc46bb9d911838edfa723d985ede6a604c0c5a (patch)
tree3ceb366c12f0bc229cfcd5fce6c2f409e29fe06b /tv/1systems/alnus.nix
parentfc3f5d3d56a299b7b46c1a42d3fec57c536a5917 (diff)
move source config from module system to 1systems/*/source.nix
Diffstat (limited to 'tv/1systems/alnus.nix')
-rw-r--r--tv/1systems/alnus.nix96
1 files changed, 0 insertions, 96 deletions
diff --git a/tv/1systems/alnus.nix b/tv/1systems/alnus.nix
deleted file mode 100644
index ef2a0500..00000000
--- a/tv/1systems/alnus.nix
+++ /dev/null
@@ -1,96 +0,0 @@
-{ config, pkgs, ... }:
-
-with import <stockholm/lib>;
-
-{
- imports = [
- ../.
- ../2configs/hw/x220.nix
- ../2configs/exim-retiolum.nix
- ../2configs/retiolum.nix
- ];
-
- # TODO remove non-hardware stuff from ../2configs/hw/x220.nix
- # networking.wireless.enable collides with networkmanager
- networking.wireless.enable = mkForce false;
-
- boot = {
- initrd = {
- availableKernelModules = [ "ahci" ];
- luks = {
- cryptoModules = [ "aes" "sha512" "xts" ];
- devices = [ { name = "luksroot"; device = "/dev/sda2"; } ];
- };
- };
- };
-
- environment.systemPackages = with pkgs; [
- chromium
- firefoxWrapper
- networkmanagerapplet
- pidginotr
- pidgin-with-plugins
- ];
-
- fileSystems = {
- "/boot" = {
- device = "/dev/sda1";
- };
- "/" = {
- device = "/dev/mapper/main-root";
- fsType = "btrfs";
- options = [ "defaults" "noatime" ];
- };
- "/home" = {
- device = "/dev/mapper/main-home";
- fsType = "btrfs";
- options = [ "defaults" "noatime" ];
- };
- };
-
- hardware = {
- opengl.driSupport32Bit = true;
- pulseaudio.enable = true;
- };
-
- i18n.defaultLocale = "de_DE.UTF-8";
-
- krebs.build = {
- host = config.krebs.hosts.alnus;
- user = mkForce config.krebs.users.dv;
- source.nixpkgs.git.ref = mkForce "9b948ea439ddbaa26740ce35543e7e35d2aa6d18";
- };
-
- networking.networkmanager.enable = true;
-
- nixpkgs.config = {
- allowUnfree = true;
- };
-
- services.xserver = {
- enable = true;
- layout = "de";
- xkbOptions = "eurosign:e";
- synaptics = {
- enable = true;
- twoFingerScroll = true;
- };
- desktopManager.xfce.enable = true;
- displayManager.auto = {
- enable = true;
- user = "dv";
- };
- };
-
- swapDevices =[ ];
-
- users.users.dv = {
- inherit (config.krebs.users.dv) home uid;
- isNormalUser = true;
- extraGroups = [
- "audio"
- "video"
- "networkmanager"
- ];
- };
-}