summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-06-30 09:44:28 +0200
committertv <tv@krebsco.de>2017-06-30 09:44:28 +0200
commitaa8fb19044cebff2d9687ab975340a7c0c96990d (patch)
treefabb9d4ae72b1d56a853217845bfec3835062bfd /shell.nix
parentc500d72ad855418b7d4d9d852d423a8a9440285c (diff)
shell: use writeOut to create cmdspkg
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/shell.nix b/shell.nix
index 782b4fa3..dbc2b14f 100644
--- a/shell.nix
+++ b/shell.nix
@@ -151,12 +151,9 @@
echo "$date.$version"
'';
- shell.cmdspkg = pkgs.runCommand "shell.cmdspkg" {} /* sh */ ''
- mkdir -p $out/bin
- ${lib.concatStrings (lib.mapAttrsToList (name: path: /* sh */ ''
- ln -s ${path} $out/bin/${name}
- '') cmds)}
- '';
+ shell.cmdspkg = pkgs.writeOut "shell.cmdspkg" (lib.mapAttrs' (name: link:
+ lib.nameValuePair "/bin/${name}" { inherit link; }
+ ) cmds);
in pkgs.stdenv.mkDerivation {
name = "stockholm";