summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-06-30 11:04:58 +0200
committertv <tv@krebsco.de>2017-06-30 11:09:19 +0200
commit9ee286644d050e68292776e02357549801fd20b6 (patch)
treeed2cd56398f4fb1aea73825a014e3513133b2f87 /shell.nix
parentbabbed38df4c0ff90eea9daa00cea3a105fb3ab2 (diff)
shell: use stockholm lib
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/shell.nix b/shell.nix
index 541a7d68..3e7ba81c 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,6 @@
-{ nixpkgs ? import <nixpkgs> { overlays = [(import ./krebs/5pkgs)]; } }: let
-
- inherit (nixpkgs) lib pkgs;
- slib = import ./lib;
+let
+ lib = import ./lib;
+ pkgs = import <nixpkgs> { overlays = [(import ./krebs/5pkgs)]; };
# usage: deploy --system=SYSTEM [--target=TARGET]
cmds.deploy = pkgs.writeDash "cmds.deploy" ''