summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-07-23 00:28:35 +0200
committertv <tv@krebsco.de>2017-07-23 01:35:58 +0200
commit4b894507b2fef23e68097bd2b758acf151ab7993 (patch)
treeeb3ccb57003dc6020b3593ac42d8871df757ac6c /shell.nix
parent854311b004c947ec825f04df9f5fb8fda777e5dc (diff)
shell: add support for --pure
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 0a8d8dde..deca2ca3 100644
--- a/shell.nix
+++ b/shell.nix
@@ -174,7 +174,8 @@ let
in pkgs.stdenv.mkDerivation {
name = "stockholm";
shellHook = /* sh */ ''
- export NIX_PATH="stockholm=$PWD''${NIX_PATH+:$NIX_PATH}"
+ export NIX_PATH=stockholm=$PWD:nixpkgs=${toString <nixpkgs>}
+ export NIX_REMOTE=daemon
export PATH=${lib.makeBinPath [
shell.cmdspkg
]}