summaryrefslogtreecommitdiffstats
path: root/shared/1systems/test-all-krebs-modules/config.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-07-11 11:26:24 +0200
committerlassulus <lassulus@lassul.us>2017-07-12 19:09:36 +0200
commit3363a8746c9152709abcd5adbbcdc00c2df0ff39 (patch)
treea10665f6ddf735eb1ac3970f2cdb24f4cf6e4ed7 /shared/1systems/test-all-krebs-modules/config.nix
parent9215b5b6880c833721caa7572b7480c7912d7fd6 (diff)
move source config from module system to 1systems/*/source.nix
Diffstat (limited to 'shared/1systems/test-all-krebs-modules/config.nix')
-rw-r--r--shared/1systems/test-all-krebs-modules/config.nix54
1 files changed, 54 insertions, 0 deletions
diff --git a/shared/1systems/test-all-krebs-modules/config.nix b/shared/1systems/test-all-krebs-modules/config.nix
new file mode 100644
index 00000000..7ebcf3b5
--- /dev/null
+++ b/shared/1systems/test-all-krebs-modules/config.nix
@@ -0,0 +1,54 @@
+{ config, pkgs, lib, ... }:
+let
+ en = { enable = true;};
+in {
+ imports = [
+ <stockholm/shared>
+ ];
+ krebs = {
+ enable = true;
+ build.user = config.krebs.users.shared;
+ build.host = config.krebs.hosts.test-all-krebs-modules;
+ Reaktor.test = {};
+ apt-cacher-ng.enable = true;
+ backup.enable = true;
+ bepasty.enable = true;
+ # FIXME fast-tests / instantiate-test-all-modules fails at wolfbot
+ # http://wolf:8010/builders/fast-tests/builds/442
+ #buildbot.master.enable = true;
+ buildbot.worker = {
+ enable = true;
+ username = "lol";
+ password = "wut";
+ };
+ # XXX exim-retiolum and exim-smarthost are mutually exclusive
+ #exim-retiolum = {
+ # enable = true;
+ # primary_hostname = "test.r";
+ #};
+ exim-smarthost = {
+ enable = true;
+ primary_hostname = "test.r";
+ system-aliases = [ { from = "dick"; to = "butt"; } ];
+ };
+ go.enable = true;
+ iptables = {
+ enable = true;
+ tables = {};
+ };
+ realwallpaper.enable = true;
+ tinc.retiolum.enable = true;
+ retiolum-bootstrap.enable = true;
+ tinc_graphs.enable = true;
+ urlwatch.enable = true;
+ fetchWallpaper = {
+ enable = true;
+ url ="localhost";
+ };
+ };
+ # just get the system running
+ boot.loader.grub.devices = ["/dev/sda"];
+ fileSystems."/" = {
+ device = "/dev/lol";
+ };
+}