summaryrefslogtreecommitdiffstats
path: root/old/modules/tv/git/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-11 19:44:12 +0200
committertv <tv@shackspace.de>2015-07-11 19:44:12 +0200
commit2bc5c58d85990e483af8fde57ed5f2442351b69c (patch)
tree94cd29e6a98f1ce6228104055d0550e318242290 /old/modules/tv/git/default.nix
parentc5fcda1390afaba71133b2ee6ac1ddd0f559ef8c (diff)
move old stuff
Diffstat (limited to 'old/modules/tv/git/default.nix')
-rw-r--r--old/modules/tv/git/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/old/modules/tv/git/default.nix b/old/modules/tv/git/default.nix
new file mode 100644
index 00000000..17bc3738
--- /dev/null
+++ b/old/modules/tv/git/default.nix
@@ -0,0 +1,27 @@
+arg@{ config, pkgs, lib, ... }:
+
+let
+ inherit (lib) mkIf mkMerge;
+
+ cfg = config.tv.git;
+ arg' = arg // { inherit cfg; };
+in
+
+# TODO unify logging of shell scripts to user and journal
+# TODO move all scripts to ${etcDir}, so ControlMaster connections
+# immediately pick up new authenticators
+# TODO when authorized_keys changes, then restart ssh
+# (or kill already connected users somehow)
+
+{
+ imports = [
+ ../../tv/nginx
+ ];
+
+ options.tv.git = import ./options.nix arg';
+
+ config = mkIf cfg.enable (mkMerge [
+ (import ./config.nix arg')
+ (mkIf cfg.cgit (import ./cgit.nix arg'))
+ ]);
+}