summaryrefslogtreecommitdiffstats
path: root/old/modules/rmdir/users.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-11 19:44:12 +0200
committertv <tv@shackspace.de>2015-07-11 19:44:12 +0200
commit2bc5c58d85990e483af8fde57ed5f2442351b69c (patch)
tree94cd29e6a98f1ce6228104055d0550e318242290 /old/modules/rmdir/users.nix
parentc5fcda1390afaba71133b2ee6ac1ddd0f559ef8c (diff)
move old stuff
Diffstat (limited to 'old/modules/rmdir/users.nix')
-rw-r--r--old/modules/rmdir/users.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/old/modules/rmdir/users.nix b/old/modules/rmdir/users.nix
new file mode 100644
index 00000000..82f078b4
--- /dev/null
+++ b/old/modules/rmdir/users.nix
@@ -0,0 +1,19 @@
+{ ... }:
+
+let
+ inherit (builtins) readFile;
+in
+
+{
+ users.extraUsers =
+ {
+ root = {
+ openssh.authorizedKeys.keys = [
+ (readFile <pubkeys/deploy_wu.ssh.pub>)
+ (readFile <pubkeys/tv_wu.ssh.pub>)
+ ];
+ };
+ };
+
+ users.mutableUsers = false;
+}