summaryrefslogtreecommitdiffstats
path: root/old/modules/rmdir/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-16 23:22:30 +0200
committertv <tv@shackspace.de>2015-07-16 23:22:30 +0200
commit57c520b722f25f384301118046bf9cf182d4edd7 (patch)
tree57983c04bb49fe0375300861111a61cede545794 /old/modules/rmdir/default.nix
parent447c63edbd403abf026800d10594ed037b4304e9 (diff)
Goodbye old world, and thanks for all the fish!
Diffstat (limited to 'old/modules/rmdir/default.nix')
-rw-r--r--old/modules/rmdir/default.nix87
1 files changed, 0 insertions, 87 deletions
diff --git a/old/modules/rmdir/default.nix b/old/modules/rmdir/default.nix
deleted file mode 100644
index 7279df77..00000000
--- a/old/modules/rmdir/default.nix
+++ /dev/null
@@ -1,87 +0,0 @@
-{ config, pkgs, ... }:
-
-let
- inherit (builtins) readFile;
-in
-
-{
- imports =
- [
- { users.extraUsers = import <secrets/extraUsers.nix>; }
- ./networking.nix
- ./users.nix
- ../tv/base.nix
- ../tv/base-cac-CentOS-7-64bit.nix
- ../tv/config/consul-server.nix
- ../tv/exim-smarthost.nix
- ../tv/git/public.nix
- ../tv/sanitize.nix
- {
- imports = [ ../tv/identity ];
- tv.identity = {
- enable = true;
- self = config.tv.identity.hosts.rmdir;
- };
- }
- {
- imports = [ ../tv/iptables ];
- tv.iptables = {
- enable = true;
- input-internet-accept-new-tcp = [
- "ssh"
- "tinc"
- "smtp"
- "xmpp-client"
- "xmpp-server"
- ];
- input-retiolum-accept-new-tcp = [
- "http"
- ];
- };
- }
- {
- imports = [ ../tv/retiolum ];
- tv.retiolum = {
- enable = true;
- hosts = <retiolum-hosts>;
- connectTo = [
- "cd"
- "mkdir"
- "fastpoke"
- "pigstarter"
- "ire"
- ];
- };
- }
- ];
-
- nix.maxJobs = 1;
-
- environment.systemPackages = with pkgs; [
- git # required for ./deploy, clone_or_update
- htop
- iftop
- iotop
- iptables
- mutt # for mv
- nethogs
- rxvt_unicode.terminfo
- tcpdump
- ];
-
- services.journald.extraConfig = ''
- SystemMaxUse=1G
- RuntimeMaxUse=128M
- '';
-
- services.openssh = {
- enable = true;
- hostKeys = [
- # XXX bits here make no science
- { bits = 8192; type = "ed25519"; path = "/etc/ssh/ssh_host_ed25519_key"; }
- ];
- permitRootLogin = "yes";
- };
-
- sound.enable = false;
-}