summaryrefslogtreecommitdiffstats
path: root/old/modules/mors/git.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-07-13 13:39:49 +0200
committerlassulus <lass@aidsballs.de>2015-07-16 15:47:28 +0200
commitd629bee9546fa6ed6a018f2b6d491a851ad12738 (patch)
tree049777923f431beab9b3fd0a5e1c3953f4418451 /old/modules/mors/git.nix
parent02261729c0a4108f2fcccf062b603d62f56782bf (diff)
"rebase"
Diffstat (limited to 'old/modules/mors/git.nix')
-rw-r--r--old/modules/mors/git.nix161
1 files changed, 110 insertions, 51 deletions
diff --git a/old/modules/mors/git.nix b/old/modules/mors/git.nix
index 1dd61d16..37506486 100644
--- a/old/modules/mors/git.nix
+++ b/old/modules/mors/git.nix
@@ -1,71 +1,130 @@
{ config, lib, pkgs, ... }:
-{
- imports = [
- ../tv/git
+let
+ inherit (builtins) map readFile;
+ inherit (lib) concatMap listToAttrs;
+ # TODO lib should already include our stuff
+ inherit (import ../../lib { inherit lib pkgs; }) addNames git;
+
+ x-repos = [
+ (krebs-private "brain")
+
+ (public "painload")
+ (public "shitment")
+ (public "wai-middleware-time")
+ (public "web-routes-wai-custom")
+
+ (secret "pass")
+
+ (tv-lass "emse-drywall")
+ (tv-lass "emse-hsdb")
];
- services.git =
- let
- inherit (builtins) readFile;
- # TODO lib should already include our stuff
- inherit (import ../../lib { inherit lib pkgs; }) addNames git;
+ users = addNames {
+ tv = { pubkey = readFile <pubkeys/tv_wu.ssh.pub>; };
+ lass = { pubkey = readFile <pubkeys/lass.ssh.pub>; };
+ uriel = { pubkey = readFile <pubkeys/uriel.ssh.pub>; };
+ makefu = { pubkey = "xxx"; };
+ };
- krebs-private = name: desc:
- {
- inherit desc;
- hooks = {
- post-receive = git.irc-announce {
- nick = config.networking.hostName; # TODO make this the default
- channel = "#retiolum";
- server = "ire.retiolum";
- };
- };
- }
- in rec {
- enable = true;
+ repos = listToAttrs (map ({ repo, ... }: { name = repo.name; value = repo; }) x-repos);
- users = addNames {
- tv = { pubkey = readFile <pubkeys/tv.ssh.pub>; };
- lass = { pubkey = readFile <pubkeys/lass.ssh.pub>; };
- uriel = { pubkey = readFile <pubkeys/lass.ssh.pub>; };
- makefu = { pubkey = "xxx"; };
- };
+ rules = concatMap ({ rules, ... }: rules) x-repos;
- repos = addNames {
- shitment = {
- desc = "shitment repository";
- hooks = {
- post-receive = git.irc-announce {
- nick = config.networking.hostName; # TODO make this the default
- channel = "#retiolum";
- server = "ire.retiolum";
- };
+ krebs-private = repo-name:
+ rec {
+ repo = {
+ name = repo-name;
+ hooks = {
+ post-receive = git.irc-announce {
+ nick = config.networking.hostName; # TODO make this the default
+ channel = "#retiolum";
+ server = "ire.retiolum";
};
- public = true;
};
- testing = {
- desc = "testing repository";
- hooks = {
- post-receive = git.irc-announce {
- nick = config.networking.hostName; # TODO make this the default
- channel = "#repository";
- server = "ire.retiolum";
- };
+ };
+ rules = with git; with users; [
+ { user = lass;
+ repo = [ repo ];
+ perm = push "refs/*" [ non-fast-forward create delete merge ];
+ }
+ { user = [ tv makefu uriel ];
+ repo = [ repo ];
+ perm = fetch;
+ }
+ ];
+ };
+
+ public = repo-name:
+ rec {
+ repo = {
+ name = repo-name;
+ hooks = {
+ post-receive = git.irc-announce {
+ nick = config.networking.hostName; # TODO make this the default
+ channel = "#retiolum";
+ server = "ire.retiolum";
};
- public = true;
};
+ public = true;
+ };
+ rules = with git; with users; [
+ { user = lass;
+ repo = [ repo ];
+ perm = push "refs/*" [ non-fast-forward create delete merge ];
+ }
+ { user = [ tv makefu uriel ];
+ repo = [ repo ];
+ perm = fetch;
+ }
+ ];
+ };
+
+ secret = repo-name:
+ rec {
+ repo = {
+ name = repo-name;
+ hooks = {};
};
+ rules = with git; with users; [
+ { user = lass;
+ repo = [ repo ];
+ perm = push "refs/*" [ non-fast-forward create delete merge ];
+ }
+ { user = [ uriel ];
+ repo = [ repo ];
+ perm = fetch;
+ }
+ ];
+ };
- rules = with git; with users; with repos; [
+ tv-lass = repo-name:
+ rec {
+ repo = {
+ name = repo-name;
+ hooks = {};
+ };
+ rules = with git; with users; [
{ user = lass;
- repo = [ testing shitment ];
- perm = push master [ non-fast-forward create delete merge ];
+ repo = [ repo ];
+ perm = push "refs/*" [ non-fast-forward create delete merge ];
}
- { user = [ tv uriel makefu ];
- repo = [ testing shitment ];
+ { user = [ tv ];
+ repo = [ repo ];
perm = fetch;
}
];
};
+
+in
+
+{
+ imports = [
+ ../tv/git
+ ];
+
+ tv.git = {
+ enable = true;
+ inherit repos rules users;
+ };
}