summaryrefslogtreecommitdiffstats
path: root/old/modules/lass/desktop-base.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-11 19:44:12 +0200
committertv <tv@shackspace.de>2015-07-11 19:44:12 +0200
commit2bc5c58d85990e483af8fde57ed5f2442351b69c (patch)
tree94cd29e6a98f1ce6228104055d0550e318242290 /old/modules/lass/desktop-base.nix
parentc5fcda1390afaba71133b2ee6ac1ddd0f559ef8c (diff)
move old stuff
Diffstat (limited to 'old/modules/lass/desktop-base.nix')
-rw-r--r--old/modules/lass/desktop-base.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/old/modules/lass/desktop-base.nix b/old/modules/lass/desktop-base.nix
new file mode 100644
index 00000000..94184548
--- /dev/null
+++ b/old/modules/lass/desktop-base.nix
@@ -0,0 +1,37 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ./base.nix
+ ];
+
+ time.timeZone = "Europe/Berlin";
+
+ virtualisation.libvirtd.enable = true;
+
+ hardware.pulseaudio = {
+ enable = true;
+ systemWide = true;
+ };
+
+ programs.ssh.startAgent = false;
+
+ security.setuidPrograms = [ "slock" ];
+
+ services.printing = {
+ enable = true;
+ drivers = [ pkgs.foomatic_filters ];
+ };
+
+ environment.systemPackages = with pkgs; [
+
+ powertop
+
+ #window manager stuff
+ haskellPackages.xmobar
+ haskellPackages.yeganesh
+ dmenu2
+ xlibs.fontschumachermisc
+ ];
+
+}