summaryrefslogtreecommitdiffstats
path: root/nin/2configs/im.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-02-28 22:51:18 +0100
committertv <tv@krebsco.de>2018-02-28 22:51:18 +0100
commitbecf1ce7ac7688692c3770571387b3761be11698 (patch)
tree6238277fa4c42de03b393d89cdbb12d8582afba4 /nin/2configs/im.nix
parent2934d4524bcbae13043d684a27597c8b08c0851b (diff)
parent793742b9d1b2eab942e5d06ed27028c636cda583 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'nin/2configs/im.nix')
-rw-r--r--nin/2configs/im.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/nin/2configs/im.nix b/nin/2configs/im.nix
new file mode 100644
index 00000000..b078dbd5
--- /dev/null
+++ b/nin/2configs/im.nix
@@ -0,0 +1,19 @@
+{ config, lib, pkgs, ... }:
+with import <stockholm/lib>;
+{
+ environment.systemPackages = with pkgs; [
+ (pkgs.writeDashBin "im" ''
+ export PATH=${makeSearchPath "bin" (with pkgs; [
+ tmux
+ gnugrep
+ weechat
+ ])}
+ ssh chat@onondaga
+ if tmux list-sessions -F\#S | grep -q '^im''$'; then
+ exec tmux attach -t im
+ else
+ exec tmux new -s im weechat
+ fi
+ '')
+ ];
+}