summaryrefslogtreecommitdiffstats
path: root/mb/2configs/headless.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2019-07-14 13:43:30 +0200
committerlassulus <lassulus@lassul.us>2019-07-14 13:43:30 +0200
commit9b0e78fcb66b0d7accf974ab4ddf8da05612c695 (patch)
treeeb41197546236a1f3c5e4efebf50c4133c8fc58f /mb/2configs/headless.nix
parent13d8d9f7d340a64cd69957854c628dc4ca0876e6 (diff)
parent976e6d77031b9e9648789d72cf893a6d1192fedb (diff)
Merge remote-tracking branch 'mb/master'
Diffstat (limited to 'mb/2configs/headless.nix')
-rw-r--r--mb/2configs/headless.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/mb/2configs/headless.nix b/mb/2configs/headless.nix
new file mode 100644
index 00000000..46a9b6a7
--- /dev/null
+++ b/mb/2configs/headless.nix
@@ -0,0 +1,25 @@
+# Common configuration for headless machines (e.g., Amazon EC2
+# instances).
+
+{ lib, ... }:
+
+with lib;
+
+{
+ boot.vesa = false;
+
+ # Don't start a tty on the serial consoles.
+ systemd.services."serial-getty@ttyS0".enable = false;
+ systemd.services."serial-getty@hvc0".enable = false;
+ systemd.services."getty@tty1".enable = false;
+ systemd.services."autovt@".enable = false;
+
+ # Since we can't manually respond to a panic, just reboot.
+ boot.kernelParams = [ "panic=1" "boot.panic_on_fail" ];
+
+ # Don't allow emergency mode, because we don't have a console.
+ systemd.enableEmergencyMode = false;
+
+ # Being headless, we don't need a GRUB splash image.
+ boot.loader.grub.splashImage = null;
+}