summaryrefslogtreecommitdiffstats
path: root/mb/1systems/gr33n/hardware-configuration.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2019-05-28 21:53:34 +0200
committerjeschli <jeschli@gmail.com>2019-05-28 21:53:34 +0200
commit89af71b0ad44862282cf26efe4d33630311296bc (patch)
tree8d327f6aa02898f9a9a4b7c3ec82fc9a4980e046 /mb/1systems/gr33n/hardware-configuration.nix
parentef05aadec954c49fee728fe46c975250346f1620 (diff)
parentbe12b8a41370f50b413376717a5db38edfebd828 (diff)
Merge branch 'master' of prism.r:stockholm
Diffstat (limited to 'mb/1systems/gr33n/hardware-configuration.nix')
-rw-r--r--mb/1systems/gr33n/hardware-configuration.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/mb/1systems/gr33n/hardware-configuration.nix b/mb/1systems/gr33n/hardware-configuration.nix
new file mode 100644
index 00000000..1d13b8dc
--- /dev/null
+++ b/mb/1systems/gr33n/hardware-configuration.nix
@@ -0,0 +1,37 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "ahci" "xhci_pci" "nvme" "usb_storage" "usbhid" "sd_mod" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ boot.initrd.mdadmConf = ''
+ ARRAY /dev/md0 level=raid6 num-devices=4 metadata=1.2 name=gr33n:0 UUID=5b715fd9:0be6bfa6:19f07db4:c16836d6
+ devices=/dev/sda1,/dev/sdb1,/dev/sdc1,/dev/sdd1
+ '';
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/a9f2c19b-f60f-450c-87f1-146a54c4198b";
+ fsType = "ext4";
+ };
+ fileSystems."/storage" =
+ { device = "/dev/disk/by-label/storage";
+ fsType = "ext4";
+ };
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/93EB-BCA3";
+ fsType = "vfat";
+ };
+
+ swapDevices = [ ];
+
+ nix.maxJobs = lib.mkDefault 4;
+ powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}