summaryrefslogtreecommitdiffstats
path: root/makefu/source.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-12-26 23:20:56 +0100
committermakefu <github@syntax-fehler.de>2017-12-26 23:20:56 +0100
commit2589f81f9a9f53ccfc40d946ca693a83f2c81900 (patch)
tree7fe091d6140bcbbb27a9243ddca9c681923e3383 /makefu/source.nix
parent96c7074c08e914a230124073ef6209bb9b888108 (diff)
x: use nixos-hardware
Diffstat (limited to 'makefu/source.nix')
-rw-r--r--makefu/source.nix18
1 files changed, 17 insertions, 1 deletions
diff --git a/makefu/source.nix b/makefu/source.nix
index ce585543..2456dc76 100644
--- a/makefu/source.nix
+++ b/makefu/source.nix
@@ -4,7 +4,9 @@ host@{ name,
secure ? false,
full ? false,
torrent ? false,
- musnix ? false
+ hw ? false,
+ musnix ? false,
+ python ? false
}:
let
builder = if getEnv "dummy_secrets" == "true"
@@ -45,6 +47,20 @@ in
ref = "d8b989f";
};
})
+
+ (mkIf ( hw ) {
+ nixos-hardware.git = {
+ url = https://github.com/makefu/nixos-hardware.git;
+ ref = "1fef1c1";
+ };
+ })
+
+ (mkIf ( python ) {
+ python.git = {
+ url = https://github.com/garbas/nixpkgs-python;
+ ref = "cac319b";
+ };
+ })
(mkIf ( torrent ) {
torrent-secrets.file = getAttr builder {
buildbot = toString <stockholm/makefu/6tests/data/secrets>;