summaryrefslogtreecommitdiffstats
path: root/makefu/krops.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-09-09 10:23:20 +0200
committertv <tv@krebsco.de>2018-09-09 10:25:02 +0200
commitdf809dca51b2a4037449d626e14a75aa91be7b3a (patch)
tree1ed7889762e67d92c880d20315e8f3fb66915396 /makefu/krops.nix
parentd3c84b0d2981f46574046e19d8e3d618065b92a0 (diff)
buildbot-stockholm: build using the test attribute
While at it, fix */krops.nix to actually use the target attribute.
Diffstat (limited to 'makefu/krops.nix')
-rw-r--r--makefu/krops.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/makefu/krops.nix b/makefu/krops.nix
index 9a701dca..30385c10 100644
--- a/makefu/krops.nix
+++ b/makefu/krops.nix
@@ -75,14 +75,9 @@ in {
target = "root@${target}/var/src";
};
- # usage: $(nix-build --no-out-link --argstr name HOSTNAME -A test)
+ # usage: $(nix-build --no-out-link --argstr name HOSTNAME --argstr target PATH -A test)
test = pkgs.krops.writeTest "${name}-test" {
+ inherit target;
source = source { test = true; };
- target = "${lib.getEnv "HOME"}/tmp/${name}-krops-test-src";
- };
-
- ci = pkgs.krops.writeTest "${name}-test" {
- source = source { test = true; };
- target = "${lib.getEnv "HOME"}/stockholm-build";
};
}