summaryrefslogtreecommitdiffstats
path: root/makefu/krops.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-03-12 20:35:48 +0100
committermakefu <github@syntax-fehler.de>2021-03-12 20:35:48 +0100
commitaa1b8ed563f9df4d6d9f4793c27e149f1e23a942 (patch)
tree4ac4523200a37f2cfe2fa67faf814c79de5f4d44 /makefu/krops.nix
parentfe393ec4e753f2b84439eb719613a9fa79ec0c15 (diff)
ma krops: add buildTarget
Diffstat (limited to 'makefu/krops.nix')
-rw-r--r--makefu/krops.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/makefu/krops.nix b/makefu/krops.nix
index a03fea02..12c003b2 100644
--- a/makefu/krops.nix
+++ b/makefu/krops.nix
@@ -1,4 +1,4 @@
-{ config ? config, name, target ? name }: let
+{ config ? config, name, target ? name , buildTarget ? target }: let
krops = ../submodules/krops;
nixpkgs-src = lib.importJSON ../krebs/nixpkgs.json;
@@ -87,6 +87,7 @@ in {
deploy = pkgs.krops.writeDeploy "${name}-deploy" {
source = source { test = false; };
target = "root@${target}/var/src";
+ buildTarget = if target == buildTarget then "root@${target}/var/src" else "root@${buildTarget}/tmp/";
};
# usage: $(nix-build --no-out-link --argstr name HOSTNAME --argstr target PATH -A test)