summaryrefslogtreecommitdiffstats
path: root/makefu/krops.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2018-11-27 21:06:20 +0100
committerlassulus <lassulus@lassul.us>2018-11-28 12:36:18 +0100
commit61f1aba8bc69dc522710d5871545cf4b4ec8645b (patch)
treef18b9c51ba927fd1056b27a871bd754a244c03a6 /makefu/krops.nix
parentd094f265061cc84d4c13082ae0a8909d8942f821 (diff)
* krops: get nixpkgs from store for ci
Diffstat (limited to 'makefu/krops.nix')
-rw-r--r--makefu/krops.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/makefu/krops.nix b/makefu/krops.nix
index 2b43d541..6c510eba 100644
--- a/makefu/krops.nix
+++ b/makefu/krops.nix
@@ -23,7 +23,17 @@
{
# nixos-18.09 @ 2018-09-18
# + uhub/sqlite: 5dd7610401747
- nixpkgs = if test || host-src.full then {
+ nixpkgs = if test then {
+ file = {
+ path = toString (pkgs.fetchFromGitHub {
+ owner = "makefu";
+ repo = "nixpkgs";
+ rev = nixpkgs-src.rev;
+ sha256 = nixpkgs-src.sha256;
+ });
+ useChecksum = true;
+ };
+ } else if host-src.full then {
git.ref = nixpkgs-src.rev;
git.url = nixpkgs-src.url;
} else if host-src.arm6 then {