summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/pfsshell
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-01-30 08:11:00 +0100
committermakefu <github@syntax-fehler.de>2018-01-30 08:11:00 +0100
commitb31a37799eff274215d4cd9d435a9c16d496a88c (patch)
tree107fb4eeca90039e66e9ce693dc9fe3a2715419a /makefu/5pkgs/pfsshell
parent71397b0aa5f27b0b6dbe22101287f60b237e32f0 (diff)
ma pkgs.pfsshell: init
Diffstat (limited to 'makefu/5pkgs/pfsshell')
-rw-r--r--makefu/5pkgs/pfsshell/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/makefu/5pkgs/pfsshell/default.nix b/makefu/5pkgs/pfsshell/default.nix
new file mode 100644
index 00000000..fc6b3706
--- /dev/null
+++ b/makefu/5pkgs/pfsshell/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, lib, pkgs, fetchurl,fetchFromGitHub, upx, wine }:
+stdenv.mkDerivation rec {
+ pname = "pfsshell";
+ version = "64f8c2";
+ name = "${pname}-${version}";
+
+ src = fetchFromGitHub {
+ owner = "makefu";
+ repo = "pfsshell";
+ rev = version;
+ sha256 = "01lbqf8s91p8id58xa16fp555i03vfycqvhv7qzpnrjy6yvp9dm8";
+ };
+
+ buildInputs = [ ];
+
+ makeFlags = [ ];
+
+ installPhase = ''
+ mkdir -p $out/bin
+ cp pfsshell $out/bin
+ '';
+
+ meta = {
+ homepage = https://github.com/uyjulian/pfsshell ;
+ description = "browse and transfer files to/from PFS filesystems";
+ };
+}