summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/novnc
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-05-12 11:35:35 +0200
committermakefu <github@syntax-fehler.de>2017-05-12 11:35:35 +0200
commit4c2408763eec98ec9cecf340dccfffa34a0c3cb0 (patch)
tree995be05e5b059970082095079c16af3a073d882d /makefu/5pkgs/novnc
parent1f9ddd9c6f8cdd9ce1b5a6bb9dc65475e2a90e62 (diff)
m: init and use 'makefu.gui.user'
Diffstat (limited to 'makefu/5pkgs/novnc')
-rw-r--r--makefu/5pkgs/novnc/default.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/makefu/5pkgs/novnc/default.nix b/makefu/5pkgs/novnc/default.nix
new file mode 100644
index 00000000..b1d62248
--- /dev/null
+++ b/makefu/5pkgs/novnc/default.nix
@@ -0,0 +1,41 @@
+{ stdenv, fetchurl, pkgs }:
+# source: https://github.com/hyphon81/Nixtack/blob/master/noVNC/noVNC.nix
+let
+in
+
+stdenv.mkDerivation rec {
+ name = "novnc-${version}";
+ version = "0.6.2";
+
+ src = fetchurl {
+ url = "https://github.com/novnc/noVNC/archive/v${version}.tar.gz";
+ sha256 = "16ygbdzdmnfg9a26d9il4a6fr16qmq0ix9imfbpzl0drfbj7z8kh";
+ };
+ p = stdenv.lib.makeBinPath [ pkgs.nettools pkgs.python27Packages.websockify
+ pkgs.coreutils pkgs.which pkgs.procps ];
+ # TODO: propagatedBuildInputs does not seem to work with shell scripts
+ patchPhase = ''
+ sed -i '1aset -efu\nexport PATH=${p}\n' utils/launch.sh
+ '';
+ installPhase = ''
+ mkdir -p $out/bin
+ cp utils/launch.sh $out/bin/launch-novnc.sh
+ chmod +x $out/bin/launch-novnc.sh
+ mkdir -p $out/images
+ cp -r images/* $out/images/
+ mkdir -p $out/include
+ cp -r include/* $out/include/
+ cp favicon.ico $out
+ cp vnc.html $out
+ cp vnc_auto.html $out
+ '';
+
+ meta = with stdenv.lib; {
+ homepage = http://novnc.com/info.html;
+ repositories.git = git://github.com/novnc/noVNC.git;
+ description = ''
+ A HTML5 VNC Client
+ '';
+ license = licenses.mpl20;
+ };
+}