summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/nodemcu-uploader
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-02-22 14:19:49 +0100
committermakefu <github@syntax-fehler.de>2016-02-22 14:19:49 +0100
commit63d2cc00b9f15565429e1ba414f5e73484f8730f (patch)
tree99f8559417527f7cc4eac8375e8caf000a8891a5 /makefu/5pkgs/nodemcu-uploader
parent74cfe87654638106f2d2a1a698814b41c2e904f2 (diff)
ma 5 nodemcu-uploader: init
Diffstat (limited to 'makefu/5pkgs/nodemcu-uploader')
-rw-r--r--makefu/5pkgs/nodemcu-uploader/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/makefu/5pkgs/nodemcu-uploader/default.nix b/makefu/5pkgs/nodemcu-uploader/default.nix
new file mode 100644
index 00000000..64476be6
--- /dev/null
+++ b/makefu/5pkgs/nodemcu-uploader/default.nix
@@ -0,0 +1,22 @@
+{ lib, pkgs, pythonPackages, fetchurl, ... }:
+
+with pythonPackages; buildPythonPackage rec {
+ name = "nodemcu-uploader-${version}";
+ version = "0.2.2";
+ disabled = isPy3k || isPyPy;
+ propagatedBuildInputs = [
+ pyserial
+ ];
+ src = fetchurl {
+ url = "https://pypi.python.org/packages/source/n/nodemcu-uploader/nodemcu-uploader-${version}.tar.gz";
+ sha256 = "090giz84y9y3idgifp0yh80qqyv2czv6h3y55wyrlgf7qfbwbrvn";
+ };
+ # ImportError: No module named tests
+ # not sure what to do here
+ doCheck = false;
+ meta = {
+ homepage = https://github.com/kmpm/nodemcu-uploader;
+ description = "tool for uploading files to NodeMCU filesystem";
+ license = lib.licenses.mit;
+ };
+}