summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/custom
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-03-13 10:39:32 +0100
committermakefu <github@syntax-fehler.de>2020-03-13 10:39:32 +0100
commita2d343e8070097de9c62f86dfd8cca883f55cd53 (patch)
tree296e8fcbb6701171cfeedea46e0177495b5895cf /makefu/5pkgs/custom
parentbf5a5fb3e0f70aeda37900e1c5ce478a2b07a764 (diff)
ma pkgs.hydra-check: move to custom
Diffstat (limited to 'makefu/5pkgs/custom')
-rw-r--r--makefu/5pkgs/custom/hydra-check/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/makefu/5pkgs/custom/hydra-check/default.nix b/makefu/5pkgs/custom/hydra-check/default.nix
new file mode 100644
index 00000000..512ceec9
--- /dev/null
+++ b/makefu/5pkgs/custom/hydra-check/default.nix
@@ -0,0 +1,19 @@
+{ docopt, requests, beautifulsoup4, fetchFromGitHub, buildPythonPackage }:
+
+buildPythonPackage rec {
+ name = "hydra-check";
+ version = "1.0.0";
+
+ src = fetchFromGitHub {
+ owner = "makefu";
+ repo = "hydra-check";
+ rev = version;
+ sha256 = "0359s9rvl2q23a3yddhbn6w2sd5r1f1jl6whyik7qql7blpcvyi7";
+ };
+ propagatedBuildInputs = [
+ docopt
+ requests
+ beautifulsoup4
+ ];
+ doCheck = false; # no tests
+}