summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/bintray-upload
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-06-23 23:13:50 +0200
committermakefu <github@syntax-fehler.de>2016-06-23 23:13:50 +0200
commit3716ece83b97500e39d08b45acf34dbb78af4b29 (patch)
tree5c2d2f552033fd0d249a385dbe4202625bacddde /makefu/5pkgs/bintray-upload
parentb709634ce9e61323b19aaf1b31c433f79f556fad (diff)
m 5 bintray-upload:init
Diffstat (limited to 'makefu/5pkgs/bintray-upload')
-rw-r--r--makefu/5pkgs/bintray-upload/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/makefu/5pkgs/bintray-upload/default.nix b/makefu/5pkgs/bintray-upload/default.nix
new file mode 100644
index 00000000..1e9582cc
--- /dev/null
+++ b/makefu/5pkgs/bintray-upload/default.nix
@@ -0,0 +1,19 @@
+{ pkgs, ... }:
+
+pkgs.python3Packages.buildPythonPackage rec {
+ name = "bintray-upload-${version}";
+ version = "0.1.2";
+ src = pkgs.fetchFromGitHub {
+ owner = "makefu";
+ repo = "bintray-upload";
+ rev = "4e76724";
+ sha256 = "1401saisk98n5wgw73nwh8hb484vayw5c6dlypxc1fp4ybym4zi9";
+ };
+
+ propagatedBuildInputs = with pkgs.python3Packages; [ requests2 ];
+
+ meta = {
+ description = "Simple BinTray utility for uploading packages";
+ license = pkgs.stdenv.lib.licenses.asl20;
+ };
+}