summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/_4nxci/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2023-07-28 22:24:15 +0200
committermakefu <github@syntax-fehler.de>2023-07-28 22:24:15 +0200
commit060a8f28fa1fc648bdf66afb31a5d1efac868837 (patch)
tree2b354eacc7897365ee45244fe7a51720e0d0333f /makefu/5pkgs/_4nxci/default.nix
parentcbfcc890e3b76d942b927809bf981a5fa7289e6a (diff)
makefu: move out to own repo, add vacation-note
Diffstat (limited to 'makefu/5pkgs/_4nxci/default.nix')
-rw-r--r--makefu/5pkgs/_4nxci/default.nix50
1 files changed, 0 insertions, 50 deletions
diff --git a/makefu/5pkgs/_4nxci/default.nix b/makefu/5pkgs/_4nxci/default.nix
deleted file mode 100644
index 47c02aca..00000000
--- a/makefu/5pkgs/_4nxci/default.nix
+++ /dev/null
@@ -1,50 +0,0 @@
-{ stdenv, lib, fetchFromGitHub, mbedtls, python2, perl }:
-let
- version = "4.03";
- src = fetchFromGitHub {
- owner = "The-4n";
- repo = "4NXCI";
- rev = "v${version}";
- sha256 = "0n49sqv6s8cj2dw1dbcyskfc2zr92p27f1bdd6jqfbawv0fqr1wf";
- };
-
- mymbedtls = stdenv.mkDerivation {
- name = "mbedtls-${version}";
- version = "2.6.1";
- doCheck = false;
- inherit src;
- buildInputs = [ perl ];
- phases = [ "unpackPhase" "buildPhase" "installPhase" ];
- makeFlags = [ "DESTDIR=$(out)" ];
- buildPhase = ''
- cp config.mk.template config.mk
- cd mbedtls
- make
- '';
- };
-in stdenv.mkDerivation rec {
- name = "4nxci-${version}";
-
- inherit src version;
- buildPhase = ''
- cp config.mk.template config.mk
- sed -i 's#\(INCLUDE =\).*#\1${mymbedtls}/include#' Makefile
- sed -i 's#\(LIBDIR =\).*#\1${mymbedtls}/lib#' Makefile
- make 4nxci
- '';
-
- installPhase = ''
- install -m755 -D 4nxci $out/bin/4nxci
- '';
-
- #preInstall = ''
- # mkdir -p $out/bin
- #'';
-
- buildInputs = [ mymbedtls ];
-
- meta = {
- description = "convert xci to nsp";
- license = lib.licenses.isc;
- };
-}