summaryrefslogtreecommitdiffstats
path: root/makefu/3modules/opentracker.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2023-07-28 22:24:15 +0200
committermakefu <github@syntax-fehler.de>2023-07-28 22:24:15 +0200
commit060a8f28fa1fc648bdf66afb31a5d1efac868837 (patch)
tree2b354eacc7897365ee45244fe7a51720e0d0333f /makefu/3modules/opentracker.nix
parentcbfcc890e3b76d942b927809bf981a5fa7289e6a (diff)
makefu: move out to own repo, add vacation-note
Diffstat (limited to 'makefu/3modules/opentracker.nix')
-rw-r--r--makefu/3modules/opentracker.nix55
1 files changed, 0 insertions, 55 deletions
diff --git a/makefu/3modules/opentracker.nix b/makefu/3modules/opentracker.nix
deleted file mode 100644
index 6c65b82b..00000000
--- a/makefu/3modules/opentracker.nix
+++ /dev/null
@@ -1,55 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with import <stockholm/lib>;
-let
- cfg = config.makefu.opentracker;
-
- out = {
- options.makefu.opentracker = api;
- config = lib.mkIf cfg.enable imp;
- };
-
- api = {
- enable = mkEnableOption "opentracker";
-
- package = mkOption {
- type = types.package;
- default = pkgs.opentracker;
- };
-
- args = mkOption {
- type = types.separatedString;
- description = ''
- see https://erdgeist.org/arts/software/opentracker/ for all params
- '';
- default = "";
- };
-
- user = mkOption {
- description = ''
- user which will run opentracker. by default opentracker drops all
- privileges and runs in chroot after starting up as root.
- '';
- type = types.str;
- default = "root";
- };
- };
-
- imp = {
- systemd.services.opentracker = {
- description = "opentracker server";
- after = [ "network.target" ];
- wantedBy = [ "multi-user.target" ];
- restartIfChanged = true;
- serviceConfig = {
- Type = "simple";
- ExecStart = "${cfg.package}/bin/opentracker ${cfg.args}";
- PrivateTmp = true;
- WorkingDirectory = "/tmp";
- User = "${cfg.user}";
- };
- };
- };
-in
-out
-