summaryrefslogtreecommitdiffstats
path: root/makefu/3modules/awesome-extra.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2023-07-28 22:24:15 +0200
committermakefu <github@syntax-fehler.de>2023-07-28 22:24:15 +0200
commit060a8f28fa1fc648bdf66afb31a5d1efac868837 (patch)
tree2b354eacc7897365ee45244fe7a51720e0d0333f /makefu/3modules/awesome-extra.nix
parentcbfcc890e3b76d942b927809bf981a5fa7289e6a (diff)
makefu: move out to own repo, add vacation-note
Diffstat (limited to 'makefu/3modules/awesome-extra.nix')
-rw-r--r--makefu/3modules/awesome-extra.nix36
1 files changed, 0 insertions, 36 deletions
diff --git a/makefu/3modules/awesome-extra.nix b/makefu/3modules/awesome-extra.nix
deleted file mode 100644
index 9e9dfdfd..00000000
--- a/makefu/3modules/awesome-extra.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-{config, lib, pkgs, ... }:
-
-with lib;
-let
- cfg = config.makefu.awesome;
- out = {
- options.makefu.awesome = api;
- config = lib.mkIf cfg.enable imp;
- };
- api = {
- enable = mkEnableOption "awesome custom config";
- modkey = mkOption {
- type = types.str;
- description = "Modkey to be used";
- default = "Mod4";
- };
- baseConfig = mkOption {
- type = types.path;
- description = ''
- rc.lua file to be used as default
- This module will use substituteAll to replace strings before writing to
- /etc/xdg/awesome/rc.lua
- '';
- default = pkgs.awesomecfg.full.override {
- locker = "${pkgs.i3lock}/bin/i3lock -i /var/lib/wallpaper/wallpaper";
- };
- };
- };
- imp = {
- home-manager.users.makefu.home.file.".config/awesome/rc.lua".source =
- cfg.baseConfig.override {
- inherit (cfg) modkey;
- };
-
- };
-in out