summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/zsh-user.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-12-08 14:30:44 +0100
committermakefu <github@syntax-fehler.de>2017-12-08 14:30:44 +0100
commit90f0675cb730e3e64b3622fd55f76c242270d672 (patch)
tree3ec590cbea87be6435709ee87a79e91d23e3155b /makefu/2configs/zsh-user.nix
parentec5069e0b6c948f8b5dbd2de591214a91ec0fa48 (diff)
ma zsh: disable manual completions, enable ctrl-xewq
Diffstat (limited to 'makefu/2configs/zsh-user.nix')
-rw-r--r--makefu/2configs/zsh-user.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/makefu/2configs/zsh-user.nix b/makefu/2configs/zsh-user.nix
index f280fc85..6be078f6 100644
--- a/makefu/2configs/zsh-user.nix
+++ b/makefu/2configs/zsh-user.nix
@@ -8,11 +8,12 @@ in
users.extraUsers.${mainUser}.shell = "/run/current-system/sw/bin/zsh";
programs.zsh= {
enable = true;
- enableCompletion = false ; #manually at the end
+ enableCompletion = true ; #manually at the end
interactiveShellInit = ''
HISTSIZE=900001
HISTFILESIZE=$HISTSIZE
SAVEHIST=$HISTSIZE
+ HISTFILE=$HOME/.zsh_history
setopt HIST_IGNORE_ALL_DUPS
setopt HIST_IGNORE_SPACE
@@ -65,13 +66,15 @@ in
zle -N fzf-file-widget
bindkey '^T' fzf-file-widget
- # Auto-Completion
- for p in ''${(z)NIX_PROFILES}; do
- fpath+=($p/share/zsh/site-functions $p/share/zsh/$ZSH_VERSION/functions $p/share/zsh/vendor-completions)
- done
- autoload -U compinit && compinit
compdef _pass brain
zstyle ':completion::complete:brain::' prefix "$HOME/brain"
+
+ # ctrl-x ctrl-e
+ autoload -U edit-command-line
+ zle -N edit-command-line
+ bindkey '^xe' edit-command-line
+ bindkey '^x^e' edit-command-line
+
'';
promptInit = ''