summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/vncserver.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-07-16 21:54:06 +0200
committermakefu <github@syntax-fehler.de>2017-07-16 21:54:06 +0200
commitab1ea28d0b6529e5ad9112513db24a52fa7994d8 (patch)
tree2cdbfbbd401b518e2494488fe7a0f682c41034d9 /makefu/2configs/vncserver.nix
parent43b9240b0ded5928c44615c7a91db7262f1017cf (diff)
ma vncserver: use upstream tigervnc again
Diffstat (limited to 'makefu/2configs/vncserver.nix')
-rw-r--r--makefu/2configs/vncserver.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/makefu/2configs/vncserver.nix b/makefu/2configs/vncserver.nix
index c56b3e29..3d1d9fe7 100644
--- a/makefu/2configs/vncserver.nix
+++ b/makefu/2configs/vncserver.nix
@@ -3,14 +3,13 @@ with lib;
let
pwfile = (toString <secrets>)+ "/vnc-password"; # create with `vncpasswd`
pwtmp = "/tmp/vnc-password";
- # nixos-unstable tigervnc is currently broken :\
- package = (import (fetchTarball https://github.com/NixOS/nixpkgs-channels/archive/nixos-17.03.tar.gz) {}).pkgs.tigervnc;
user = config.makefu.gui.user;
vnc_port = 5900;
web_port = 6080;
in {
networking.firewall.allowedTCPPorts = [ 80 vnc_port web_port ];
systemd.services = {
+ # TODO: terminal-server without a real gui and virtual display manager
terminal-server = {
description = "VNC Terminal Server";
after = [ "display-manager.service" "graphical.target" ];
@@ -22,7 +21,7 @@ in {
sleep 5
install -m0700 -o ${user} ${pwfile} ${pwtmp}
'';
- ExecStart = "${package}/bin/x0vncserver -display :0 -rfbport ${toString vnc_port} -passwordfile ${pwtmp}";
+ ExecStart = "${pkgs.tigervnc}/bin/x0vncserver -display :0 -rfbport ${toString vnc_port} -passwordfile ${pwtmp}";
PermissionsStartOnly = true;
PrivateTmp = true;
};