summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/torrent.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-12-28 16:10:07 +0100
committermakefu <github@syntax-fehler.de>2017-12-28 16:10:07 +0100
commitce8efbc80bc05f27f55ea87be2d826134afec6fd (patch)
tree7dc5584a3b69b1950d24a3af446b9307ee3df363 /makefu/2configs/torrent.nix
parent5af2f438441c46bc508a038303b6e36946f7f5d4 (diff)
ma torrent: set workDir instead of downloadDir
Diffstat (limited to 'makefu/2configs/torrent.nix')
-rw-r--r--makefu/2configs/torrent.nix13
1 files changed, 6 insertions, 7 deletions
diff --git a/makefu/2configs/torrent.nix b/makefu/2configs/torrent.nix
index d063ad3e..a076479c 100644
--- a/makefu/2configs/torrent.nix
+++ b/makefu/2configs/torrent.nix
@@ -8,13 +8,13 @@ let
peer-port = 51412;
web-port = 8112;
daemon-port = 58846;
- dl-dir = config.makefu.dl-dir;
+ torrent-dir = config.makefu.dl-dir;
in {
users.users = {
download = {
name = "download";
- home = dl-dir;
+ home = torrent-dir;
uid = mkDefault (genid "download");
createHome = true;
useDefaultShell = true;
@@ -26,9 +26,9 @@ in {
# todo: race condition, do this after download user has been created
system.activationScripts."download-dir-chmod" = ''
for i in finished watch torrents; do
- mkdir -p "${dl-dir}/$i"
- chown download:download "${dl-dir}/$i"
- chmod 770 "${dl-dir}/$i"
+ mkdir -p "${torrent-dir}/$i"
+ chown download:download "${torrent-dir}/$i"
+ chmod 770 "${torrent-dir}/$i"
done
'';
@@ -54,9 +54,8 @@ in {
rutorrent.enable = true;
enableXMLRPC = true;
listenPort = peer-port;
- downloadDir = dl-dir + "/finished";
+ workDir = torrent-dir;
# dump old torrents into watch folder to have them re-added
- watchDir = dl-dir +"/watch";
};
networking.firewall.extraCommands = ''