summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/torrent.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-09-25 14:19:11 +0200
committermakefu <github@syntax-fehler.de>2019-09-25 14:20:13 +0200
commit60087eedb934ee2361fcffc3779151cbac1c2336 (patch)
tree87f4287ad6d9eb743829b23f2bfad9fe971ebaa6 /makefu/2configs/torrent.nix
parent9fb322853726c5dd4a027aa1ce681278434fc256 (diff)
ma torrent: log rpc events, cleanup
Diffstat (limited to 'makefu/2configs/torrent.nix')
-rw-r--r--makefu/2configs/torrent.nix16
1 files changed, 14 insertions, 2 deletions
diff --git a/makefu/2configs/torrent.nix b/makefu/2configs/torrent.nix
index ca368dbf..9b736537 100644
--- a/makefu/2configs/torrent.nix
+++ b/makefu/2configs/torrent.nix
@@ -35,7 +35,9 @@ in {
rtorrent.members = [ "download" ];
};
- krebs.rtorrent = {
+ krebs.rtorrent = let
+ d = config.makefu.dl-dir;
+ in {
enable = true;
web = {
enable = true;
@@ -45,7 +47,17 @@ in {
rutorrent.enable = true;
enableXMLRPC = true;
listenPort = peer-port;
- downloadDir = config.makefu.dl-dir;
+ downloadDir = d + "/finished/incoming";
+ watchDir = d + "/watch";
+ # TODO: maybe test out multiple watch dirs with tags: https://github.com/rakshasa/rtorrent/wiki/TORRENT-Watch-directories
+ extraConfig = ''
+ # log.add_output = "debug", "rtorrent-systemd"
+ # log.add_output = "dht_debug", "rtorrent-systemd"
+ # log.add_output = "tracker_debug", "rtorrent-systemd"
+ log.add_output = "rpc_events", "rtorrent-systemd"
+ log.add_output = "rpc_dump", "rtorrent-systemd"
+ system.daemon.set = true
+ '';
# dump old torrents into watch folder to have them re-added
};