summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/torrent.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-08-22 18:41:42 +0200
committermakefu <github@syntax-fehler.de>2016-08-22 18:41:42 +0200
commit5557ae25660e3934582050865e8dcfc0f93f5856 (patch)
treeca70ed300342941badf5c7e2cbe0a3c1966a3226 /makefu/2configs/torrent.nix
parentf75a11a2da87ebd5e8735f77cebb61ebd0f8bfae (diff)
m 2 torrent: update config for otpimized seeding
Diffstat (limited to 'makefu/2configs/torrent.nix')
-rw-r--r--makefu/2configs/torrent.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/makefu/2configs/torrent.nix b/makefu/2configs/torrent.nix
index c18db9fa..09f3ca05 100644
--- a/makefu/2configs/torrent.nix
+++ b/makefu/2configs/torrent.nix
@@ -55,20 +55,21 @@ in {
autoadd_enable = true;
download_location = dl-dir + "/finished";
torrentfiles_location = dl-dir + "/torrents"; copy_torrent_file = true;
- lsd = true;
- dht = true;
- upnp = true;
- natpmp = true;
+ lsd = false;
+ dht = false;
+ upnp = false;
+ natpmp = false;
add_paused = false;
allow_remote = true;
remove_seed_at_ratio = false;
move_completed = false;
daemon_port = daemon-port;
+ random_port = false;
+ random_outgoing_ports = true;
listen_ports = [ peer-port peer-port ];
- outgoing_ports = [ peer-port peer-port ];
# performance tuning
cache_expiry = 3600;
- stop_seed_at_ratio = true;
+ stop_seed_at_ratio = false;
};
};