summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/torrent.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-12-22 15:41:49 +0100
committermakefu <github@syntax-fehler.de>2016-12-22 15:41:49 +0100
commit06e57a836224ea6db3bdd5a109e0347d824f47e5 (patch)
tree81a85cbdabdeb409840251d390f50e45571b2ac5 /makefu/2configs/torrent.nix
parentdace21d1636724d58a4412c3b40690d8f8df7d3f (diff)
m 2 torrent: use new krebs.rtorrent api
Diffstat (limited to 'makefu/2configs/torrent.nix')
-rw-r--r--makefu/2configs/torrent.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/makefu/2configs/torrent.nix b/makefu/2configs/torrent.nix
index 5b9ce617..f3bc9091 100644
--- a/makefu/2configs/torrent.nix
+++ b/makefu/2configs/torrent.nix
@@ -4,7 +4,7 @@ with import <stockholm/lib>;
let
daemon-user = "tor";
- authfile = <torrent-secrets/authfile>;
+ basicAuth = import <torrent-secrets/auth.nix>;
peer-port = 51412;
web-port = 8112;
daemon-port = 58846;
@@ -53,9 +53,8 @@ in {
enable = true;
web = {
enable = true;
- enableAuth = true;
- listenAddress = toString web-port;
- inherit authfile;
+ port = web-port;
+ inherit basicAuth;
};
rutorrent.enable = true;
enableXMLRPC = true;