summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/syncthing.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-09-17 01:10:36 +0200
committermakefu <github@syntax-fehler.de>2018-09-17 01:10:36 +0200
commit80250950625cceb084ed4251082a01fbd8de2bc1 (patch)
tree024fa1f692e89628a546b00a30775e4dd4b56c6d /makefu/2configs/syncthing.nix
parent14cb17d0ce26f74434e68d2266ed2f3b8a1a3f0b (diff)
ma syncthing: track syncthing state
Diffstat (limited to 'makefu/2configs/syncthing.nix')
-rw-r--r--makefu/2configs/syncthing.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/makefu/2configs/syncthing.nix b/makefu/2configs/syncthing.nix
index 6b758ea2..bc7413a0 100644
--- a/makefu/2configs/syncthing.nix
+++ b/makefu/2configs/syncthing.nix
@@ -1,11 +1,17 @@
-{...}:
+{ config, ... }:
with import <stockholm/lib>; {
services.syncthing = {
enable = true;
openDefaultPorts = true;
- useInotify = true;
group = "download";
};
users.extraGroups.download.gid = genid "download";
+ state = map (x: config.services.syncthing.dataDir + "/" + x) [
+ "key.pem"
+ "cert.pem"
+ "config.xml"
+ "https-cert.pem"
+ "https-key.pem"
+ ];
}