summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/share/omo.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-05-25 23:19:36 +0200
committermakefu <github@syntax-fehler.de>2017-05-25 23:19:36 +0200
commit0c92dd719a46139523f6e353c354871bd78024a4 (patch)
treeb57b178de784847d9e0748a748412178762d621b /makefu/2configs/share/omo.nix
parent243d33abe350a1a7b41a7f2c6106fd5b92bde4c8 (diff)
m 2: rename stats and share
Diffstat (limited to 'makefu/2configs/share/omo.nix')
-rw-r--r--makefu/2configs/share/omo.nix69
1 files changed, 69 insertions, 0 deletions
diff --git a/makefu/2configs/share/omo.nix b/makefu/2configs/share/omo.nix
new file mode 100644
index 00000000..7d7a4ec5
--- /dev/null
+++ b/makefu/2configs/share/omo.nix
@@ -0,0 +1,69 @@
+{ config, lib, pkgs, ... }:
+
+with import <stockholm/lib>;
+let
+ hostname = config.krebs.build.host.name;
+ # TODO local-ip from the nets config
+ local-ip = "192.168.1.11";
+ # local-ip = config.krebs.build.host.nets.retiolum.ip4.addr;
+in {
+
+ # samba share /media/crypt1/share
+ users.users.smbguest = {
+ name = "smbguest";
+ uid = config.ids.uids.smbguest;
+ description = "smb guest user";
+ home = "/var/empty";
+ };
+ services.samba = {
+ enable = true;
+ shares = {
+ winshare = {
+ path = "/media/crypt1/share";
+ "read only" = "no";
+ browseable = "yes";
+ "guest ok" = "yes";
+ };
+ emu = {
+ path = "/media/crypt1/emu";
+ "read only" = "yes";
+ browseable = "yes";
+ "guest ok" = "yes";
+ };
+ usenet = {
+ path = "/media/crypt0/usenet/dst";
+ "read only" = "yes";
+ browseable = "yes";
+ "guest ok" = "yes";
+ };
+ pyload = {
+ path = "/media/crypt0/pyload";
+ "read only" = "yes";
+ browseable = "yes";
+ "guest ok" = "yes";
+ };
+ crypt0 = {
+ path = "/media/crypt0";
+ "read only" = "yes";
+ browseable = "yes";
+ "guest ok" = "yes";
+ };
+ media-rw = {
+ path = "/media/";
+ "read only" = "no";
+ browseable = "yes";
+ "guest ok" = "no";
+ "valid users" = "makefu";
+ };
+ };
+ extraConfig = ''
+ guest account = smbguest
+ map to guest = bad user
+ # disable printing
+ load printers = no
+ printing = bsd
+ printcap name = /dev/null
+ disable spoolss = yes
+ '';
+ };
+}