summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/remote-build/arm-emulation.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2023-07-28 22:24:15 +0200
committermakefu <github@syntax-fehler.de>2023-07-28 22:24:15 +0200
commit060a8f28fa1fc648bdf66afb31a5d1efac868837 (patch)
tree2b354eacc7897365ee45244fe7a51720e0d0333f /makefu/2configs/remote-build/arm-emulation.nix
parentcbfcc890e3b76d942b927809bf981a5fa7289e6a (diff)
makefu: move out to own repo, add vacation-note
Diffstat (limited to 'makefu/2configs/remote-build/arm-emulation.nix')
-rw-r--r--makefu/2configs/remote-build/arm-emulation.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/makefu/2configs/remote-build/arm-emulation.nix b/makefu/2configs/remote-build/arm-emulation.nix
deleted file mode 100644
index dbef2522..00000000
--- a/makefu/2configs/remote-build/arm-emulation.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{ pkgs, ... }:
-let qemu-arm-static = pkgs.stdenv.mkDerivation {
- name = "qemu-arm-static";
- src = builtins.fetchurl {
- url = "https://github.com/multiarch/qemu-user-static/releases/download/v6.1.0-8/qemu-arm-static";
- sha256 = "06344d77d4f08b3e1b26ff440cb115179c63ca8047afb978602d7922a51231e3";
- };
- dontUnpack = true;
- installPhase = "install -D -m 0755 $src $out/bin/qemu-arm-static";
-};
-in {
- # Enable binfmt emulation of extra binary formats (armv7l-linux, for exmaple).
- boot.binfmt.emulatedSystems = [ "aarch64-linux" ];
- boot.binfmt.registrations.arm = {
- interpreter = "${qemu-arm-static}/bin/qemu-arm-static";
- magicOrExtension = ''\x7fELF\x01\x01\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x02\x00\x28\x00'';
- mask = ''\xff\xff\xff\xff\xff\xff\xff\x00\xff\xff\xff\xff\xff\xff\x00\xff\xfe\xff\xff\xff'';
- };
-
- # Define additional settings for nix.
- nix.extraOptions = ''
- extra-platforms = armv7l-linux
- '';
- nix.sandboxPaths = [ "/run/binfmt/arm=${qemu-arm-static}/bin/qemu-arm-static" ];
-}