summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/nginx/share-download.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-01-09 16:02:20 +0100
committermakefu <github@syntax-fehler.de>2017-01-09 16:02:20 +0100
commiteb208085f011aa48bae73b98caa1f4fccae74ab6 (patch)
treebeaf43be755e186076ef3cbaaef0f5cee87f150d /makefu/2configs/nginx/share-download.nix
parent1ca165d96d21e13f5c62e9a0a45d21ecef984992 (diff)
m 2 nginx/share-download: expose dl-dir via nginx
Diffstat (limited to 'makefu/2configs/nginx/share-download.nix')
-rw-r--r--makefu/2configs/nginx/share-download.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/makefu/2configs/nginx/share-download.nix b/makefu/2configs/nginx/share-download.nix
new file mode 100644
index 00000000..65c44b29
--- /dev/null
+++ b/makefu/2configs/nginx/share-download.nix
@@ -0,0 +1,18 @@
+{ config, lib, pkgs, ... }:
+
+with import <stockholm/lib>;
+{
+ services.nginx = {
+ enable = mkDefault true;
+ recommendedGzipSettings = true;
+ recommendedOptimisation = true;
+ virtualHosts."dl.euer.krebsco.de" = {
+ root = config.makefu.dl-dir;
+ extraConfig = "autoindex on;";
+ forceSSL = true;
+ enableSSL = true;
+ enableACME = true;
+ basicAuth = import <secrets/dl.euer.krebsco.de-auth.nix>;
+ };
+ };
+}